Can't play Mabinogi on (my) windows 8.1 (nor on my XP) (rev. 1 by OniZero on 02-27-18, 06:46 am)
Posted at 02-27-18, 06:45 am Link | #1
OniZero

Posts: 7
Joined: 02-26-18
Last post: 28 days
Last view: 8 days
'Sup people, i tried to launch the game on my desktop with windows 8.1 and i get the error 0xc0150002 (on the notebook that has XP it just says is not compatible with Win32 ) is there any way to fix the issue(s)? (without having to spend 5 hours just to download the installer all over again if possible)
Posted at 03-04-18, 07:13 pm Link | #2
Stilva

Posts: 26
Joined: 02-14-18
Last post: 2 days
Last view: 1 day
As far as I can tell, that error means you need to update your Visual C++ from Microsoft. They offer the downloads for free on their site.
post rev. 1 by OniZero on 03-05-18, 10:55 am
Posted at 03-05-18, 07:47 am Link | #3
OniZero

Posts: 7
Joined: 02-26-18
Last post: 28 days
Last view: 8 days
Downloaded updates, ran CCleaner, uninstalled obsolete versions, restarted PC, installed update, ran CClearer, restarted PC, nothing has changed... at all.

Edit: In a little twist Nexon's launcher installed VC++ 2010 to run the official mabinogi server despite having 2017 installed... the private server is still giving the same error
Posted at 03-31-18, 04:37 am Link | #4
Drahan GM

Posts: 1801
Joined: 02-06-17
Last post: 27 min.
Last view: 25 min.
Our launcher does not support Windows XP unfortunately.

As for 0xc0150002, you need to install the VC++ 2008 Redistributable from here:
https://www.microsoft.com/en-us/download/details.aspx?id=29
post rev. 4 by OniZero on 04-08-18, 05:14 pm
Posted at 04-04-18, 10:22 pm Link | #5
OniZero

Posts: 7
Joined: 02-26-18
Last post: 28 days
Last view: 8 days
Our launcher does not support Windows XP unfortunately.

As for 0xc0150002, you need to install the VC++ 2008 Redistributable from here:
https://www.microsoft.com/en-us/download/details.aspx?id=29
http://prntscr.com/j0z55o

I got told to follow the FAQ thread
http://prntscr.com/j0z7ar
http://prntscr.com/j0z7rm
Translation is petty much windows refused (and can't) since you shouldn't run the launcher without DEP.

I've tried the remaining ones and... well, i haven't seen any other changes besides being now unable to check the error log that comes with the crash notification window.

Edit:Holy shit guys this waiting game is actually putting my capacity to not go either batshit, despair or outrcy to it's limit
Edit2: The first screenshot shows that i have from the version of VC++ 2008 that i was told to get installed up to 2017 (it overwrites VC++2015)
Posted at 04-08-18, 06:21 pm Link | #6
Drahan GM

Posts: 1801
Joined: 02-06-17
Last post: 27 min.
Last view: 25 min.
Our launcher does not support Windows XP unfortunately.

As for 0xc0150002, you need to install the VC++ 2008 Redistributable from here:
https://www.microsoft.com/en-us/download/details.aspx?id=29
http://prntscr.com/j0z55o

I got told to follow the FAQ thread
http://prntscr.com/j0z7ar
http://prntscr.com/j0z7rm
Translation is petty much windows refused (and can't) since you shouldn't run the launcher without DEP.

I've tried the remaining ones and... well, i haven't seen any other changes besides being now unable to check the error log that comes with the crash notification window.

Edit:Holy shit guys this waiting game is actually putting my capacity to not go either batshit, despair or outrcy to it's limit
Edit2: The first screenshot shows that i have from the version of VC++ 2008 that i was told to get installed up to 2017 (it overwrites VC++2015)
Ignore setting the launcher's DEP, it isnt required.
Only Client.exe really needs DEP disabled.

If this doesn't work, unfortunately, there is likely not much we can do.
If you have followed the FAQ to it's fullest extent and it still doesn't work, there is not much hope.

I will build a version of our launcher that will work on Windows XP for you, so you can play on your Windows XP computer.
Give me a bit to do this.
Posted at 04-08-18, 06:34 pm Link | #7
Drahan GM

Posts: 1801
Joined: 02-06-17
Last post: 27 min.
Last view: 25 min.
You can download the Windows XP compatible launcher here:
http://mabi.pro/patch/MabiProXPLauncher.zip

Please note, this is untested as I do not have a Windows XP computer.

This requires that you have .NET 3.5 installed (it should be installed on Win XP SP2 by default?)
You can find that here if it doesn't already work:
https://www.microsoft.com/en-us/download/details.aspx?id=21
post rev. 3 by despair on 04-08-18, 09:40 pm
Posted at 04-08-18, 09:38 pm Link | #8
despair

Posts: 4
Joined: 03-03-17
Last post: 41 days
Last view: 25 days
Technically, now that the launcher has been patched, this should now work properly on a fully patched Windows 2000 SP4 system with .NET 2.0 SP2 and Visual C++ 9.0 libc runtime installed. Previously, one had to patch manually on Windows XP or 2000.

source: still use an old laptop from time to time to test my own projects and code on
-despair
Posted at 04-12-18, 05:54 pm Link | #9
OniZero

Posts: 7
Joined: 02-26-18
Last post: 28 days
Last view: 8 days
You can download the Windows XP compatible launcher here:
http://mabi.pro/patch/MabiProXPLauncher.zip

Please note, this is untested as I do not have a Windows XP computer.

This requires that you have .NET 3.5 installed (it should be installed on Win XP SP2 by default?)
You can find that here if it doesn't already work:
https://www.microsoft.com/en-us/download/details.aspx?id=21
Hold on a second, before just spending a while.... A WHILE moving the data from the computer to the laptop i have to ask, did i ever needed framework on the windows 8.1? if so then that explains the problem i have (this extralite version of 8.1 rejects all the versions of windows framework)
post rev. 1 by OniZero on 04-14-18, 02:09 am
Posted at 04-14-18, 02:08 am Link | #10
OniZero

Posts: 7
Joined: 02-26-18
Last post: 28 days
Last view: 8 days
I don't know what the hell happened but i wiped all the data on the HDD, split the HDD and after giving new format to it, proceeded to install both XP and 8.1, on XP i ran (forcefully installed) from net framework 1.1 to 4 (only on the part of the HDD reserved for windows XP) and downloaded the patch on the game files, now the game works on XP and 8.1, no VC++ downloaded or anything (although i'm getting told on 8.1 that the graphic card is obsolete since the driver is as old as the installation of this customized XP).
Posted at 05-15-18, 01:47 pm Link | #11
Drahan GM

Posts: 1801
Joined: 02-06-17
Last post: 27 min.
Last view: 25 min.
I don't know what the hell happened but i wiped all the data on the HDD, split the HDD and after giving new format to it, proceeded to install both XP and 8.1, on XP i ran (forcefully installed) from net framework 1.1 to 4 (only on the part of the HDD reserved for windows XP) and downloaded the patch on the game files, now the game works on XP and 8.1, no VC++ downloaded or anything (although i'm getting told on 8.1 that the graphic card is obsolete since the driver is as old as the installation of this customized XP).

I too don't know what happened, but that is good news!
Terms

Powered by mabi.pro v1.0034-arisa (View credits)
MabiPro is not associated with Nexon Co., Ltd. in any way shape or form.